Test - HTTP API latency degradation

Medium · Resolved · Mar 17, 2026 · Duration: 15m

We've started responding more slowly, if you're getting timeouts, retrying requests should work.

Mar 17, 2026 19:01 UTC
Investigating
We found the root cause, it's slow database queries, and we're working on a fix.
Mar 17, 2026 19:08 UTC
Identified
We found the root cause,
Mar 17, 2026 19:08 UTC
Monitoring
Fix is on PROD and working well
Mar 17, 2026 19:08 UTC
Resolved
All good